Documentation forAppOptics

Supported Components

This document lists the support matrix on various versions of Python and some frameworks.

Python versions (cPython)
Python 2 2.7 (ancestor module appoptics version <= 2.0.3 also supports Python 2.6)
Python 3 3.4, 3.5, 3.6, 3.7, 3.8

Web Frameworks
Django 1.8, 1.10, 1.11, 2.0, 2.1, 2.2, 3.0 Pyramid 1.9, 1.10
Tornado 4.1, 4.2, 4.3, 4.4, 4.5, 5.1, 6.1 Generic WSGI including Flask  

Databases and ORMs
SQLAlchemy 1.0, 1.1, 1.2, 1.3 PyMongo  
DjangoORM Sqlite, Mysql, Postgres, Oracle Redis 2.7, 2.8, 2.9, 2.10

Python RPC Clients
httplib urllib2
httplib2 urllib3
urllib requests

Other components
Memcache pylibmc