Requirements for NPM versions that support the legacy installation procedure

Review the following requirements: