SolarWinds UDT Upgrade Guide

Updated December 4, 2018

This page is for upgrading an existing installation of User Device Tracker. For fresh installations of SolarWinds UDT, see the UDT Installation Guide.

About upgrading UDT 3.3 and later

Before you upgrade UDT 3.3 or later, here's what you should know:

  • Always upgrade NPM first if you have it installed. NPM includes platform features to support all Orion products.
  • If you have SAM without NPM, upgrade SAM first. SAM includes platform features to support all Orion products.
  • From UDT 3.3, UDT no longer supports Windows OS 2008 and 2008 R2 and Microsoft SQL Server 2008 R2.
  • UDT 3.3.0 is not compatible with NCM 7.6. To install UDT 3.3.0 or upgrade from UDT 3.2.4 to UDT 3.3.0, NCM 7.6 must be upgraded to NCM 7.7 version.
  • UDT 3.3.2 is not compatible with NCM 7.7 or earlier.

Upgrading multiple products? See our SolarWinds multiple products upgrade guide!

Upgrade instructions for UDT 3.3 and later

Use the SolarWinds Orion Installer to upgrade UDT 3.3 and later.

Upgrade instructions for UDT 3.2.4 and earlier